CVE-2019-10405 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.main:jenkins-core. EPSS puts its 30-day exploitation probability at 65.3% (99th percentile). A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Jenkins
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins 2.196 and earlier, LTS 2.176.3 and earlier printed the value of the "Cookie" HTTP request header on the /whoAmI/ URL, allowing attackers exploiting another XSS vulnerability to obtain the HTTP session cookie despite it being marked HttpOnly.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.main:jenkins-core | all versions | 2.176.4org.jenkins-ci.main:jenkins-core:2.176.4 |
| ☕Maven | org.jenkins-ci.main:jenkins-core | ≥ 2.177&&< 2.197 | 2.197org.jenkins-ci.main:jenkins-core:2.197 |
Affected Products
jenkinsjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.main:jenkins-core to 2.176.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10405 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2019-10405
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2019-10405 -u https://target- Template
- Jenkins <=2.196 - Cookie Exposure
- Severity
- medium
- Impact
- The exposure of cookies can lead to session hijacking, unauthorized access, and potential data breaches.
- Remediation
- Upgrade Jenkins to a version higher than 2.196 to mitigate the vulnerability.
Template by ProjectDiscovery nuclei-templates (c-sh0), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | jenkins-0:2.176.4.1578402941-1.el7 | RHBA-2020:0017 |
| Red Hat OpenShift Container Platform 4.3 | jenkins-0:2.204.1.1578490170-1.el7 | RHBA-2020:0063 |
Frequently Asked Questions
Is CVE-2019-10405 in your dependencies?
Find it across Maven, including transitive dependencies.