NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-10392 — git-client

HIGHFix: jenkinsci/git-client-plugin@899123f

CVE-2019-10392 is a high-severity (CVSS 8.8) OS Command Injection vulnerability in org.jenkins-ci.plugins:git-client. 6 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jenkins-ci.plugins:git-client — see the affected versions and patch details below.

Improper Neutralization of Special Elements used in an OS Command in Jenkins Git Client Plugin

Also known asGHSA-hw6x-2qwv-rxr7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
6 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
23.1%probability of exploitation in next 30 days
Moderate Risk-3.15%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
5.76%36.6%67.3%98.1%80.8%23.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:git-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Git Client Plugin 2.8.4 and earlier and 3.0.0-rc did not properly restrict values passed as URL argument to an invocation of 'git ls-remote', resulting in OS command injection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:git-clientall versions2.8.5org.jenkins-ci.plugins:git-client:2.8.5

Affected Products

1 product · 2 configurations
Application
git clientjenkins
≤ 2.8.4
1 version
3.0.0
Exploits & PoCs
6

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:git-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:git-client to 2.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10392 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1591354111-1.el7RHSA-2020:2478
Red Hat OpenShift Container Platform 4.1atomic-enterprise-service-catalog-1:4.1.37-202003020601.git.0.5784dc4.el7RHBA-2020:0690
Red Hat OpenShift Container Platform 4.2atomic-enterprise-service-catalog-1:4.2.20-202002170402.git.1.159e2f5.el7RHBA-2020:0522
Red Hat OpenShift Container Platform 4.3atomic-enterprise-service-catalog-1:4.3.3-202002170501.git.1.f30799e.el7RHBA-2020:0527

Frequently Asked Questions

Jenkins Git Client Plugin 2.8.4 and earlier and 3.0.0-rc did not properly restrict values passed as URL argument to an invocation of 'git ls-remote', resulting in OS command injection.
O3 Security · Impact-Aware SCA

Is CVE-2019-10392 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10392: git-client — Fixed in 2.8.5