NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-10370 — mask-passwords

MEDIUMFix: jenkinsci/mask-passwords-plugin#20

CVE-2019-10370 is a medium-severity (CVSS 6.5) CWE-532 vulnerability in org.jenkins-ci.plugins:mask-passwords. A fix is available for org.jenkins-ci.plugins:mask-passwords — see the affected versions and patch details below.

Insertion of Sensitive Information into Log File in Jenkins Mask Passwords Plugin

Also known asGHSA-gp67-c7j2-2qg2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.60%1.20%1.80%0.1%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:mask-passwords

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Mask Passwords Plugin 2.12.0 and earlier transmits globally configured passwords in plain text as part of the configuration form, potentially resulting in their exposure.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:mask-passwordsall versions2.13.0org.jenkins-ci.plugins:mask-passwords:2.13.0

Affected Products

1 product · 1 configurations
Application
mask passwordsjenkins
≤ 2.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:mask-passwords, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:mask-passwords to 2.13.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10370 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins Mask Passwords Plugin 2.12.0 and earlier transmits globally configured passwords in plain text as part of the configuration form, potentially resulting in their exposure.
O3 Security · Impact-Aware SCA

Is CVE-2019-10370 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10370: mask-passwords — Fixed in 2.13.0