NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-10356 — script-security

HIGH

CVE-2019-10356 is a high-severity (CVSS 8.8) remote code execution vulnerability in org.jenkins-ci.plugins:script-security. A fix is available for org.jenkins-ci.plugins:script-security — see the affected versions and patch details below.

Return of Pointer Value Outside of Expected Rang in Jenkins Script Security Plugin

Also known asGHSA-x25x-j4w4-7m59
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.08%2.16%3.24%0.0%2.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:script-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related to the handling of method pointer expressions allowed attackers to execute arbitrary code in sandboxed scripts.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:script-securityall versions1.62org.jenkins-ci.plugins:script-security:1.62

Affected Products

2 products · 3 configurations
Application
script securityjenkins
≤ 1.61
range
Application
openshift container platformredhat
2 versions
3.114.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:script-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:script-security to 1.62 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10356 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1566492396-1.el7RHSA-2019:2651
Red Hat OpenShift Container Platform 4.1jenkins-2-plugins-0:4.1.1567707934-1.el7RHSA-2019:2662

Frequently Asked Questions

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related to the handling of method pointer expressions allowed attackers to execute arbitrary code in sandboxed scripts.
O3 Security · Impact-Aware SCA

Is CVE-2019-10356 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10356: script-security RCE — Fixed in 1.62