CVE-2019-10195 — freeipa
MEDIUMCVE-2019-10195 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in freeipa. A fix is available for freeipa — see the affected versions and patch details below.
FreeIPA logs passwords embedded in commands in calls using batch
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
freeipa🐍freeipa🐍freeipa🐍ipa🐍ipa🐍ipaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | freeipa | ≥ 4.6.0&&< 4.6.7 | 4.6.7pip install --upgrade 'freeipa==4.6.7' |
| 🐍PyPI | freeipa | ≥ 4.7.0&&< 4.7.4 | 4.7.4pip install --upgrade 'freeipa==4.7.4' |
| 🐍PyPI | freeipa | ≥ 4.8.0&&< 4.8.3 | 4.8.3pip install --upgrade 'freeipa==4.8.3' |
| 🐍PyPI | ipa | ≥ 4.6.0&&< 4.6.7 | 4.6.7pip install --upgrade 'ipa==4.6.7' |
| 🐍PyPI | ipa | ≥ 4.7.0&&< 4.7.4 | 4.7.4pip install --upgrade 'ipa==4.7.4' |
| 🐍PyPI | ipa | ≥ 4.8.0&&< 4.8.3 | 4.8.3pip install --upgrade 'ipa==4.8.3' |
Affected Products
fedorafedoraprojectfreeipafreeipaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for freeipa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update freeipa to 4.6.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10195 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability exists in the server component of FreeIPA. Client packages are not affected.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | ipa-0:4.6.5-11.el7_7.4 | RHSA-2020:0378 |
| Red Hat Enterprise Linux 8 | idm:DL1-8010020191127093529.6573b795 | RHBA-2019:4268 |
| Red Hat Enterprise Linux 8.0 Update Services for SAP Solutions | idm:DL1-8000020200217171713.2874843d | RHSA-2020:1269 |
Frequently Asked Questions
Is CVE-2019-10195 in your dependencies?
Find it across PyPI, including transitive dependencies.