NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-10189 — moodle

MEDIUM

CVE-2019-10189 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

moodle Improper Access Control

Also known asGHSA-h7xp-7fjp-ghhc
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk-0.02%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.93%1.39%0.2%0.9%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in an assignment group could modify group overrides for other groups in the same assignment.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.7.0&&< 3.7.13.7.1composer require moodle/moodle:^3.7.1
🐘Packagistmoodle/moodle≥ 3.6.0&&< 3.6.53.6.5composer require moodle/moodle:^3.6.5
🐘Packagistmoodle/moodleall versions3.5.7composer require moodle/moodle:^3.5.7

Affected Products

1 product · 3 configurations
Application
moodlemoodle
≥ 3.7.0 && < 3.7.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10189 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in an assignment group could modify group overrides for other groups in the same assignment.
O3 Security · Impact-Aware SCA

Is CVE-2019-10189 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-10189: moodle — Fixed in 3.7.1