CVE-2019-10071 — tapestry-core
CRITICALCVE-2019-10071 is a critical-severity (CVSS 9.8) CWE-203 vulnerability in org.apache.tapestry:tapestry-core. A fix is available for org.apache.tapestry:tapestry-core — see the affected versions and patch details below.
Timing attack on HMAC signature comparison in Apache Tapestry
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tapestry:tapestry-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The code which checks HMAC in form submissions used String.equals() for comparisons, which results in a timing side channel for the comparison of the HMAC signatures. This could lead to remote code execution if an attacker is able to determine the correct signature for their payload. The comparison should be done with a constant time algorithm instead.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tapestry:tapestry-core | ≥ 5.4&&< 5.4.5 | 5.4.5org.apache.tapestry:tapestry-core:5.4.5 |
Affected Products
tapestryapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tapestry:tapestry-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tapestry:tapestry-core to 5.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10071 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-10071 in your dependencies?
Find it across Maven, including transitive dependencies.