NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-1003027 — octopusdeploy

MEDIUM

CVE-2019-1003027 is a medium-severity (CVSS 4.3) Server-Side Request Forgery (SSRF) vulnerability in hudson.plugins.octopusdeploy:octopusdeploy. A fix is available for hudson.plugins.octopusdeploy:octopusdeploy — see the affected versions and patch details below.

SSRF vulnerability due to missing permission check in Jenkins OctopusDeploy Plugin

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.51%1.02%1.53%0.0%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕hudson.plugins.octopusdeploy:octopusdeploy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenhudson.plugins.octopusdeploy:octopusdeployall versions1.9.0hudson.plugins.octopusdeploy:octopusdeploy:1.9.0

Affected Products

1 product · 1 configurations
Application
octopusdeployjenkins
≤ 1.8.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hudson.plugins.octopusdeploy:octopusdeploy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hudson.plugins.octopusdeploy:octopusdeploy to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-1003027 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.
O3 Security · Impact-Aware SCA

Is CVE-2019-1003027 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-1003027: octopusdeploy SSRF — Fixed in 1.9.0