CVE-2019-0976 is a medium-severity (CVSS 5.5) vulnerability in NuGet.Commands. A fix is available for NuGet.Commands — see the affected versions and patch details below.
NuGet Package Manager Tampering Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
NuGet.CommandsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A tampering vulnerability exists in the NuGet Package Manager for Linux and Mac that could allow an authenticated attacker to modify contents of the intermediate build folder (by default obj), aka 'NuGet Package Manager Tampering Vulnerability'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | NuGet.Commands | ≥ 5.0.0&&< 5.0.2 | 5.0.2dotnet add package NuGet.Commands --version 5.0.2 |
Affected Products
nugetmicrosoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for NuGet.Commands, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update NuGet.Commands to 5.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0976 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-0976 in your dependencies?
Find it across NuGet, including transitive dependencies.