NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-0186 — chatRoomDemo

MEDIUM

CVE-2019-0186 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.portals.pluto:chatRoomDemo. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.portals.pluto:chatRoomDemo — see the affected versions and patch details below.

Cross-site Scripting in Apache Pluto Chatroom demo

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
20.6%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
1.29%9.23%17.2%25.1%5.8%20.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.portals.pluto:chatRoomDemo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The input fields of the Apache Pluto "Chat Room" demo portlet 3.0.0 and 3.0.1 are vulnerable to Cross-Site Scripting (XSS) attacks. Mitigation: * Uninstall the ChatRoomDemo war file - or - * migrate to version 3.1.0 of the chat-room-demo war file

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.portals.pluto:chatRoomDemo≥ 3.0.0&&< 3.1.03.1.0org.apache.portals.pluto:chatRoomDemo:3.1.0

Affected Products

1 product · 2 configurations
Application
plutoapache
2 versions
3.0.03.0.1
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46759webappsjava

Apache Pluto 3.0.0 / 3.0.1 - Persistent Cross-Site Scripting

by Dhiraj Mishra · Apr 26, 2019

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.portals.pluto:chatRoomDemo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.portals.pluto:chatRoomDemo to 3.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0186 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The input fields of the Apache Pluto "Chat Room" demo portlet 3.0.0 and 3.0.1 are vulnerable to Cross-Site Scripting (XSS) attacks. Mitigation: * Uninstall the ChatRoomDemo war file - or - * migrate to version 3.1.0 of the chat-room-demo war file
O3 Security · Impact-Aware SCA

Is CVE-2019-0186 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-0186: chatRoomDemo XSS — Fixed in 3.1.0