NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2018-9057 — terraform-provider-aws

CRITICALFix: terraform-providers/terraform-provider-aws#3934

CVE-2018-9057 is a critical-severity (CVSS 9.8) CWE-332 vulnerability in github.com/hashicorp/terraform-provider-aws. A fix is available for github.com/hashicorp/terraform-provider-aws — see the affected versions and patch details below.

HashiCorp Terraform Amazon Web Services (AWS) uses an insecure PRNG

Also known asGHSA-r48h-jr2j-9g78
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.85%1.69%2.54%0.5%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/hashicorp/terraform-provider-aws

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

aws/resource_aws_iam_user_login_profile.go in the HashiCorp Terraform Amazon Web Services (AWS) provider through v1.12.0 has an inappropriate PRNG algorithm and seeding, which makes it easier for remote attackers to obtain access by leveraging an IAM account that was provisioned with a weak password.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/hashicorp/terraform-provider-awsall versions1.14.0go get github.com/hashicorp/terraform-provider-aws@v1.14.0

Affected Products

1 product · 1 configurations
Application
terraformhashicorp
≤ 1.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/terraform-provider-aws, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/hashicorp/terraform-provider-aws to 1.14.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-9057 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

aws/resource_aws_iam_user_login_profile.go in the HashiCorp Terraform Amazon Web Services (AWS) provider through v1.12.0 has an inappropriate PRNG algorithm and seeding, which makes it easier for remote attackers to obtain access by leveraging an IAM account that was provisioned with a weak password.
O3 Security · Impact-Aware SCA

Is CVE-2018-9057 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2018-9057: terraform-provider-aws — Fixed in 1.14.0