NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2018-8073 — yii2-redis

CRITICAL

CVE-2018-8073 is a critical-severity (CVSS 9.8) Code Injection vulnerability in yiisoft/yii2-redis. A fix is available for yiisoft/yii2-redis — see the affected versions and patch details below.

yii2-redis Potential Remote code execution

Also known asGHSA-4hx3-m8w5-g5qh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.41%0.97%1.53%2.09%0.9%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘yiisoft/yii2-redis

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Potential remote code execution in LUA context of the redis server via methods yii\redis\ActiveRecord::findOne() and yii\redis\ActiveRecord::findAll() in yiisoft/yii2-redis. Attackers could probably manipulate data on the redis server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistyiisoft/yii2-redisall versions2.0.8composer require yiisoft/yii2-redis:^2.0.8

Affected Products

1 product · 1 configurations
Application
yiiyiiframework
< 2.0.15
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yiisoft/yii2-redis, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update yiisoft/yii2-redis to 2.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-8073 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Potential remote code execution in LUA context of the redis server via methods `yii\redis\ActiveRecord::findOne()` and `yii\redis\ActiveRecord::findAll()` in yiisoft/yii2-redis. Attackers could probably manipulate data on the redis server.
O3 Security · Impact-Aware SCA

Is CVE-2018-8073 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-8073: yii2-redis RCE — Fixed in 2.0.8