NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-7198 — blog-plugin

MEDIUMFix: rainlab/blog-plugin@6ae19a6

CVE-2018-7198 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in rainlab/blog-plugin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for rainlab/blog-plugin — see the affected versions and patch details below.

October CMS - RainLab Blog Plugin XSS

Also known asGHSA-96mh-7xpr-qcgw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.58%1.35%2.12%2.89%1.1%2.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘rainlab/blog-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The RainLab Blog Plugin used in October CMS through 1.0.431 allows XSS by entering HTML on the Add Posts page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistrainlab/blog-pluginall versions1.4.1composer require rainlab/blog-plugin:^1.4.1

Affected Products

1 product · 1 configurations
Application
octoberoctobercms
≤ 1.0.431
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44144webappsphp

October CMS < 1.0.431 - Cross-Site Scripting

by Samrat Das · Feb 19, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rainlab/blog-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rainlab/blog-plugin to 1.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7198 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The RainLab Blog Plugin used in October CMS through 1.0.431 allows XSS by entering HTML on the Add Posts page.
O3 Security · Impact-Aware SCA

Is CVE-2018-7198 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-7198: blog-plugin XSS — Fixed in 1.4.1