NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-6591 — converse.js

MEDIUMFix: conversejs/converse.js@ba09996

CVE-2018-6591 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in converse.js. A fix is available for converse.js — see the affected versions and patch details below.

Converse.js Exposure of Sensitive Information

Also known asGHSA-mv4h-qm24-x4gh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.07%1.60%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
converse.jsnpm
2Kdownloads / week

Description

Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmconverse.jsall versions3.3.3npm install converse.js@3.3.3
🐘Packagistjcbrand/converse.jsall versions3.3.3composer require jcbrand/converse.js:^3.3.3

Affected Products

1 product · 1 configurations
Application
converse.jsconversejs
≤ 3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for converse.js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update converse.js to 3.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-6591 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.
O3 Security · Impact-Aware SCA

Is CVE-2018-6591 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2018-6591: converse.js Info Disclosure — Fixed in 3.3.3