NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-3258 — mysql-connector-java

HIGH

CVE-2018-3258 is a high-severity (CVSS 8.8) vulnerability in mysql:mysql-connector-java. A fix is available for mysql:mysql-connector-java — see the affected versions and patch details below.

Improper Privilege Management in MySQL Connectors Java

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2018-3258.

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
3.24%3.70%4.16%4.63%4.1%3.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕mysql:mysql-connector-java

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 8.0.12 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.0 Base Score 8.8 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenmysql:mysql-connector-javaall versions8.0.13mysql:mysql-connector-java:8.0.13

Affected Products

1 product · 1 configurations
Application
connector\/joracle
≤ 8.0.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mysql:mysql-connector-java, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mysql:mysql-connector-java to 8.0.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-3258 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Re Hat Satellite does not support using mysql as a back end database, thus the mysql connector is not used in any Satellite installation. The package mariadb Java client is now available in Red Hat Software Collections. It can be installed this way: ~~~ yum-config-manager --enable rhel-server-rhscl-7-rpms yum install…

ProductFixed inAdvisory
Red Hat Fuse 7.3.1mysql-connector-javaRHSA-2019:1545
Red Hat Satellite 6.8 for RHEL 7ansible-collection-redhat-satellite-0:1.3.0-1.el7satRHSA-2020:4366

Frequently Asked Questions

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 8.0.12 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.0 Base Score 8.8 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H).
O3 Security · Impact-Aware SCA

Is CVE-2018-3258 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-3258: mysql-connector-java — Fixed in 8.0.13