NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-25080 — mobiledetectlib

MEDIUMFix: serbanghita/Mobile-Detect@31818a4

CVE-2018-25080 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mobiledetect/mobiledetectlib. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mobiledetect/mobiledetectlib — see the affected versions and patch details below.

Cross-site Scripting in MobileDetect

Also known asGHSA-r77c-qv68-j3pp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
1.65%2.42%3.18%3.95%3.5%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘mobiledetect/mobiledetectlib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability, which was classified as problematic, has been found in MobileDetect 2.8.31. This issue affects the function initLayoutType of the file examples/session_example.php of the component Example. The manipulation of the argument $_SERVER['PHP_SELF'] leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.8.32 is able to address this issue. The identifier of the patch is 31818a441b095bdc4838602dbb17b8377d1e5cce. It is recommended to upgrade the affected component. The identifier VDB-220061 was assigned to this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmobiledetect/mobiledetectliball versions2.8.32composer require mobiledetect/mobiledetectlib:^2.8.32

Affected Products

1 product · 1 configurations
Application
mobiledetectmobiledetect
1 version
2.8.31
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52454webappsphp

MobileDetect 2.8.31 - Cross-Site Scripting (XSS)

by CodeSecLab · Dec 3, 2025

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mobiledetect/mobiledetectlib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mobiledetect/mobiledetectlib to 2.8.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-25080 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A vulnerability, which was classified as problematic, has been found in MobileDetect 2.8.31. This issue affects the function initLayoutType of the file examples/session_example.php of the component Example. The manipulation of the argument $_SERVER['PHP_SELF'] leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.8.32 is able to address this issue. The identifier of the patch is 31818a441b095bdc4838602dbb17b8377d1e5cce. It is recommended to upgrade the affected component. The identifier VDB-2200
O3 Security · Impact-Aware SCA

Is CVE-2018-25080 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-25080: mobiledetectlib XSS — Fixed in 2.8.32