NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2018-25077 — mel-spintax

HIGHFix: melnaron/mel-spintax@3776761

CVE-2018-25077 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in mel-spintax. A fix is available for mel-spintax — see the affected versions and patch details below.

mel-spintax has Inefficient Regular Expression Complexity

Also known asGHSA-qjm7-55vv-3c5f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.95%1.42%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mel-spintaxnpm
306downloads / week

Description

A vulnerability was found in melnaron mel-spintax. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/spintax.js. The manipulation of the argument text leads to inefficient regular expression complexity. The name of the patch is 37767617846e27b87b63004e30216e8f919637d3. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-218456.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmel-spintaxall versions1.0.3npm install mel-spintax@1.0.3

Affected Products

1 product · 1 configurations
Application
mel-spintaxmel-spintax_project
< 2018-06-02
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mel-spintax, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mel-spintax to 1.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-25077 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A vulnerability was found in melnaron mel-spintax. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/spintax.js. The manipulation of the argument text leads to inefficient regular expression complexity. The name of the patch is 37767617846e27b87b63004e30216e8f919637d3. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-218456.
O3 Security · Impact-Aware SCA

Is CVE-2018-25077 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-25077: mel-spintax — Fixed in 1.0.3