NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2018-21246 — caddy

CRITICALFix: caddyserver/caddy#2099

CVE-2018-21246 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in github.com/caddyserver/caddy. A fix is available for github.com/caddyserver/caddy — see the affected versions and patch details below.

Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication

Also known asGHSA-gr7w-x2jp-3xgwGO-2020-0043
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.88%1.66%2.44%3.22%1.4%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/caddyserver/caddy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Caddy before 0.10.13 mishandles TLS client authentication, as demonstrated by an authentication bypass caused by the lack of the StrictHostMatching mode.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/caddyserver/caddyall versions0.10.13go get github.com/caddyserver/caddy@v0.10.13

Affected Products

1 product · 1 configurations
Application
caddycaddyserver
< 0.10.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/caddyserver/caddy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/caddyserver/caddy to 0.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-21246 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Caddy before 0.10.13 mishandles TLS client authentication, as demonstrated by an authentication bypass caused by the lack of the StrictHostMatching mode.
O3 Security · Impact-Aware SCA

Is CVE-2018-21246 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2018-21246: caddy Auth Bypass — Fixed in 0.10.13