NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-20962 — crud

MEDIUMFix: Laravel-Backpack/CRUD@8b6bd0a

CVE-2018-20962 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in backpack/crud. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for backpack/crud — see the affected versions and patch details below.

Backpack\CRUD for Laravel XSS Vulnerability

Also known asGHSA-6gfm-gpr3-8wh9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.60%1.21%1.81%0.3%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘backpack/crud

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbackpack/crudall versions3.4.9composer require backpack/crud:^3.4.9

Affected Products

1 product · 1 configurations
Application
backpack\\crudbackpackforlaravel
< 3.4.9
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for backpack/crud, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update backpack/crud to 3.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-20962 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
O3 Security · Impact-Aware SCA

Is CVE-2018-20962 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-20962: crud XSS — Fixed in 3.4.9