NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-19995 — dolibarr

MEDIUMFix: Dolibarr/dolibarr@4b8be6e

CVE-2018-19995 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in dolibarr/dolibarr. A fix is available for dolibarr/dolibarr — see the affected versions and patch details below.

Dolibarr stored cross-site scripting (XSS) vulnerability

Also known asGHSA-3v8x-286h-9pxp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.61%0.1%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘dolibarr/dolibarr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting (XSS) vulnerability in Dolibarr 8.0.2 allows remote authenticated users to inject arbitrary web script or HTML via the "address" (POST) or "town" (POST) parameter to user/card.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdolibarr/dolibarrall versions8.0.4composer require dolibarr/dolibarr:^8.0.4

Affected Products

1 product · 1 configurations
Application
dolibarr erp\/crmdolibarr
1 version
8.0.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dolibarr/dolibarr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dolibarr/dolibarr to 8.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19995 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting (XSS) vulnerability in Dolibarr 8.0.2 allows remote authenticated users to inject arbitrary web script or HTML via the "address" (POST) or "town" (POST) parameter to user/card.php.
O3 Security · Impact-Aware SCA

Is CVE-2018-19995 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-19995: dolibarr XSS — Fixed in 8.0.4