NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1999026 — ecutest

MEDIUMFix: jenkinsci/ecutest-plugin@943c4d3

CVE-2018-1999026 is a medium-severity (CVSS 6.5) Server-Side Request Forgery (SSRF) vulnerability in de.tracetronic.jenkins.plugins:ecutest. A fix is available for de.tracetronic.jenkins.plugins:ecutest — see the affected versions and patch details below.

Jenkins TraceTronic ECU-TEST Plugin server-side request forgery vulnerability

Also known asGHSA-hp7x-282p-hhr9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.0%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕de.tracetronic.jenkins.plugins:ecutest

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A server-side request forgery vulnerability exists in Jenkins TraceTronic ECU-TEST Plugin 2.3 and earlier in ATXPublisher.java that allows attackers to have Jenkins send HTTP requests to an attacker-specified host.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavende.tracetronic.jenkins.plugins:ecutestall versions2.4de.tracetronic.jenkins.plugins:ecutest:2.4

Affected Products

1 product · 1 configurations
Application
tracetronic ecu-testjenkins
≤ 2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for de.tracetronic.jenkins.plugins:ecutest, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update de.tracetronic.jenkins.plugins:ecutest to 2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1999026 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

A server-side request forgery vulnerability exists in Jenkins TraceTronic ECU-TEST Plugin 2.3 and earlier in ATXPublisher.java that allows attackers to have Jenkins send HTTP requests to an attacker-specified host.
O3 Security · Impact-Aware SCA

Is CVE-2018-1999026 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1999026: ecutest SSRF — Fixed in 2.4