NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-1999002 — jenkins-core

HIGHFix: jenkinsci/jenkins@29ca81d

CVE-2018-1999002 is a high-severity (CVSS 7.5) vulnerability in org.jenkins-ci.main:jenkins-core. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Improper Input Validation in Jenkins

Also known asGHSA-qf38-f2fr-q4x9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
5 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
86.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
84.3%88.1%92.0%95.8%92.8%86.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A arbitrary file read vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers to send crafted HTTP requests returning the contents of any file on the Jenkins master file system that the Jenkins master has access to.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.121.2org.jenkins-ci.main:jenkins-core:2.121.2
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.122&&< 2.1322.132org.jenkins-ci.main:jenkins-core:2.132

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≥ 2.122 && ≤ 2.132
range
Application
communications cloud native core automated test suiteoracle
1 version
1.9.0
Exploits & PoCs
5

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46453webappsjava

Jenkins Plugin Script Security 1.49/Declarative 1.3.4/Groovy 2.60 - Remote Code Execution

by wetw0rk · Feb 25, 2019

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.121.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1999002 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A arbitrary file read vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers to send crafted HTTP requests returning the contents of any file on the Jenkins master file system that the Jenkins master has access to.
O3 Security · Impact-Aware SCA

Is CVE-2018-1999002 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1999002: jenkins-core — Fixed in 2.121.2