NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-19413 — sonar-plugin-api

MEDIUMFix: SonarSource/sonarqube@7b567ba

CVE-2018-19413 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in org.sonarsource.sonarqube:sonar-plugin-api. A fix is available for org.sonarsource.sonarqube:sonar-plugin-api — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor in SonarSource SonarQube API

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.04%0.58%1.11%1.65%0.5%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.sonarsource.sonarqube:sonar-plugin-api

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability in the API of SonarSource SonarQube before 7.5 could allow an authenticated user to discover sensitive information such as valid user-account logins in the web application. The vulnerability occurs because of improperly configured access controls that cause the API to return the externalIdentity field to non-administrator users. The attacker could use this information in subsequent attacks against the system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.sonarsource.sonarqube:sonar-plugin-apiall versions7.5org.sonarsource.sonarqube:sonar-plugin-api:7.5

Affected Products

1 product · 1 configurations
Application
sonarqubesonarsource
< 7.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.sonarsource.sonarqube:sonar-plugin-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.sonarsource.sonarqube:sonar-plugin-api to 7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19413 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A vulnerability in the API of SonarSource SonarQube before 7.5 could allow an authenticated user to discover sensitive information such as valid user-account logins in the web application. The vulnerability occurs because of improperly configured access controls that cause the API to return the externalIdentity field to non-administrator users. The attacker could use this information in subsequent attacks against the system.
O3 Security · Impact-Aware SCA

Is CVE-2018-19413 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-19413: sonar-plugin-api — Fixed in 7.5