NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2018-19048 — simditor

MEDIUMFix: mycolorway/simditor@ef01a64

CVE-2018-19048 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in simditor. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for simditor — see the affected versions and patch details below.

Cross-Site Scripting in simditor

Also known asGHSA-8v67-x8q5-3x3g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.68%1.36%2.04%0.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

34other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
simditornpm
548downloads / week

Description

Versions of simditor prior to 2.3.22 are vulnerable to Cross-Site Scripting. The package does not sanitize user input that is rendered with innerHTML, allowing attackers to execute arbitrary JavaScript.

Recommendation

Upgrade to version 2.3.22 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsimditorall versions2.3.22npm install simditor@2.3.22

Affected Products

1 product · 1 configurations
Application
simditormycolorway
≤ 2.3.21
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simditor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simditor to 2.3.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19048 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of `simditor` prior to 2.3.22 are vulnerable to Cross-Site Scripting. The package does not sanitize user input that is rendered with `innerHTML`, allowing attackers to execute arbitrary JavaScript. ## Recommendation Upgrade to version 2.3.22 or later.
O3 Security · Impact-Aware SCA

Is CVE-2018-19048 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-19048: simditor XSS — Fixed in 2.3.22