CVE-2018-17856 — framework
HIGHCVE-2018-17856 is a high-severity (CVSS 7.2) remote code execution vulnerability in joomla/framework. A fix is available for joomla/framework — see the affected versions and patch details below.
Joomla RCE Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
joomla/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Joomla! before 3.8.13. com_joomlaupdate allows the execution of arbitrary code. The default ACL config enabled the ability of Administrator-level users to access com_joomlaupdate and trigger code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | joomla/framework | ≥ 2.5.4&&< 3.8.13 | 3.8.13composer require joomla/framework:^3.8.13 |
Affected Products
joomla\!joomlaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joomla/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update joomla/framework to 3.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-17856 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-17856 in your dependencies?
Find it across Packagist, including transitive dependencies.