NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-16808 — dolibarr

MEDIUM

CVE-2018-16808 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in dolibarr/dolibarr. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for dolibarr/dolibarr — see the affected versions and patch details below.

Dolibarr Stored Cross-site Scripting in expensereport/card.php

Also known asGHSA-r3r5-fqfm-9wrh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.99%1.48%0.2%1.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘dolibarr/dolibarr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Dolibarr through 7.0.0. There is Stored XSS in expensereport/card.php in the expense reports plugin via the comments parameter, or a public or private note.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdolibarr/dolibarrall versions7.0.1composer require dolibarr/dolibarr:^7.0.1

Affected Products

1 product · 1 configurations
Application
dolibarrdolibarr
≥ 3.8.0 && ≤ 7.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dolibarr/dolibarr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dolibarr/dolibarr to 7.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16808 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in Dolibarr through 7.0.0. There is Stored XSS in expensereport/card.php in the expense reports plugin via the comments parameter, or a public or private note.
O3 Security · Impact-Aware SCA

Is CVE-2018-16808 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-16808: dolibarr XSS — Fixed in 7.0.1