NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2018-16395 — openssl

CRITICALFix: ruby/openssl@f653cfa

CVE-2018-16395 is a critical-severity (CVSS 9.8) vulnerability in openssl. EPSS puts its 30-day exploitation probability at 10.7% (96th percentile). A fix is available for openssl — see the affected versions and patch details below.

Ruby Openssl Allows Incorrect Value Comparison

Also known asGHSA-mmrq-6999-72v8
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
2.54%5.89%9.25%12.6%4.4%10.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎openssl💎openssl

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsopensslall versions2.0.9bundle update openssl --conservative
💎RubyGemsopenssl≥ 2.1.0&&< 2.1.22.1.2bundle update openssl --conservative

Affected Products

5 products · 13 configurations
OS
ubuntu linuxcanonical
4 versions
14.0416.0418.0418.10
OS
debian linuxdebian
2 versions
8.09.0
OS
enterprise linuxredhat
1 version
7.4
Application
opensslruby-lang
< 2.1.2
range
Application
rubyruby-lang
≥ 2.5.0 && ≤ 2.5.1
1 version
2.6.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openssl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openssl to 2.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16395 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Subscription Asset Manager is now in a reduced support phase receiving only Critical impact security fixes. This issue has been rated as having a security impact of Important, and is not currently planned to be addressed in future updates. Red Hat Virtualization includes a vulnerable version of ruby, however the…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ruby-0:2.0.0.648-34.el7_6RHSA-2018:3738
Red Hat Enterprise Linux 7.4 Extended Update Supportruby-0:2.0.0.648-34.el7_4RHSA-2019:1948
Red Hat Enterprise Linux 7.5 Extended Update Supportruby-0:2.0.0.648-34.el7_5RHSA-2019:2565
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby23-ruby-0:2.3.8-69.el6RHSA-2018:3729
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby24-ruby-0:2.4.5-91.el6RHSA-2018:3730
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby25-ruby-0:2.5.3-6.el7RHSA-2018:3731

Frequently Asked Questions

An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in sign
O3 Security · Impact-Aware SCA

Is CVE-2018-16395 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2018-16395: openssl — Fixed in 2.0.9