CVE-2018-15751 — salt
CRITICALCVE-2018-15751 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.
SaltStack Salt Remote command execution and incorrect access control when using salt-api
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
salt🐍salt🐍saltReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
SaltStack Salt 2016.11.x before 2016.11.10, 2017.7.x before 2017.7.8 and 2018.3.x before 2018.3.3 allow remote attackers to bypass authentication and execute arbitrary commands via salt-api(netapi).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | ≥ 2017.7.0&&< 2017.7.8 | 2017.7.8pip install --upgrade 'salt==2017.7.8' |
| 🐍PyPI | salt | ≥ 2018.3.0&&< 2018.3.3 | 2018.3.3pip install --upgrade 'salt==2018.3.3' |
| 🐍PyPI | salt | ≥ 2016.11.0&&< 2016.11.10 | 2016.11.10pip install --upgrade 'salt==2016.11.10' |
Affected Products
saltsaltstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 2017.7.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-15751 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2018-15751 in your dependencies?
Find it across PyPI, including transitive dependencies.