CVE-2018-15601 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in elefant/cms. A fix is available for elefant/cms — see the affected versions and patch details below.
Elefant CMS Improper Input Validation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
elefant/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
apps/filemanager/handlers/upload/drop.php in Elefant CMS 2.0.3 performs a urldecode step too late in the "Cannot upload executable files" protection mechanism.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | elefant/cms | all versions | 2.0.4composer require elefant/cms:^2.0.4 |
Affected Products
elefantcmselefantcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elefant/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update elefant/cms to 2.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-15601 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-15601 in your dependencies?
Find it across Packagist, including transitive dependencies.