NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2018-15531 — javamelody-core

CRITICALFix: javamelody/javamelody@ef11182

CVE-2018-15531 is a critical-severity (CVSS 9.8) XML External Entity (XXE) vulnerability in net.bull.javamelody:javamelody-core. EPSS puts its 30-day exploitation probability at 27.9% (98th percentile). A fix is available for net.bull.javamelody:javamelody-core — see the affected versions and patch details below.

JavaMelody has XXE via parseSoapMethodName in bull/javamelody/PayloadNameRequestWrapper.java.

Also known asGHSA-6fvx-r7hx-3vh6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
27.9%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
15.3%20.5%25.6%30.8%18.2%27.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕net.bull.javamelody:javamelody-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JavaMelody before 1.74.0 has XXE via parseSoapMethodName in bull/javamelody/PayloadNameRequestWrapper.java.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavennet.bull.javamelody:javamelody-coreall versions1.74.0net.bull.javamelody:javamelody-core:1.74.0

Affected Products

1 product · 1 configurations
Application
javamelodyjavamelody_project
< 1.74.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.bull.javamelody:javamelody-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update net.bull.javamelody:javamelody-core to 1.74.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-15531 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

JavaMelody before 1.74.0 has XXE via parseSoapMethodName in bull/javamelody/PayloadNameRequestWrapper.java.
O3 Security · Impact-Aware SCA

Is CVE-2018-15531 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-15531: javamelody-core XXE — Fixed in 1.74.0