NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2018-14065 — common

CRITICALFix: PHPOffice/Common#23

CVE-2018-14065 is a critical-severity (CVSS 9.8) XML External Entity (XXE) vulnerability in phpoffice/common. A fix is available for phpoffice/common — see the affected versions and patch details below.

PHPOffice Common Improper Restriction of XML External Entity Reference

Also known asGHSA-2853-hf2g-9843
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.90%1.81%2.71%0.4%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpoffice/common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

XMLReader.php in PHPOffice Common before 0.2.9 allows XXE.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpoffice/commonall versions0.2.9composer require phpoffice/common:^0.2.9

Affected Products

1 product · 1 configurations
Application
commonphpoffice_project
< 0.2.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpoffice/common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpoffice/common to 0.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14065 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

XMLReader.php in PHPOffice Common before 0.2.9 allows XXE.
O3 Security · Impact-Aware SCA

Is CVE-2018-14065 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-14065: common XXE — Fixed in 0.2.9