CVE-2018-14020 — paymorrow-module
MEDIUMCVE-2018-14020 is a medium-severity (CVSS 5.3) vulnerability in oxid-esales/paymorrow-module. A fix is available for oxid-esales/paymorrow-module — see the affected versions and patch details below.
Paymorrow Improper Input Validation vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
oxid-esales/paymorrow-module🐘oxid-esales/paymorrow-moduleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the Paymorrow module 1.0.0 before 1.0.2 and 2.0.0 before 2.0.1 for OXID eShop. An attacker can bypass delivery-address change detection if the payment module doesn't use eShop's checkout procedure properly. To do so, the attacker must change the delivery address to one that is not verified by the Paymorrow module.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | oxid-esales/paymorrow-module | ≥ 1.0.0&&< 1.0.2 | 1.0.2composer require oxid-esales/paymorrow-module:^1.0.2 |
| 🐘Packagist | oxid-esales/paymorrow-module | ≥ 2.0.0&&< 2.0.1 | 2.0.1composer require oxid-esales/paymorrow-module:^2.0.1 |
Affected Products
paymorrowpaymorrowDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oxid-esales/paymorrow-module, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update oxid-esales/paymorrow-module to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14020 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-14020 in your dependencies?
Find it across Packagist, including transitive dependencies.