CVE-2018-13390 — cloudtoken
MEDIUMCVE-2018-13390 is a medium-severity (CVSS 6.1) vulnerability in cloudtoken. A fix is available for cloudtoken — see the affected versions and patch details below.
Cloudtoken Insufficiently Protects Credentials
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cloudtokenReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Unauthenticated access to cloudtoken daemon on Linux via network from version 0.1.1 before version 0.1.24 allows attackers on the same subnet to gain temporary AWS credentials for the users' roles.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cloudtoken | ≥ 0.1.1&&< 0.1.24 | 0.1.24pip install --upgrade 'cloudtoken==0.1.24' |
Affected Products
cloudtokenatlassianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cloudtoken, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cloudtoken to 0.1.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-13390 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-13390 in your dependencies?
Find it across PyPI, including transitive dependencies.