NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2018-1309 — nifi-standard-processors

CRITICALFix: apache/nifi@28067a2

CVE-2018-1309 is a critical-severity (CVSS 9.8) XML External Entity (XXE) vulnerability in org.apache.nifi:nifi-standard-processors. A fix is available for org.apache.nifi:nifi-standard-processors — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in Apache NiFi

Also known asGHSA-42wx-65g4-5cxv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
3.17%3.79%4.40%5.02%3.7%4.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.nifi:nifi-standard-processors

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache NiFi External XML Entity issue in SplitXML processor. Malicious XML content could cause information disclosure or remote code execution. The fix to disable external general entity parsing and disallow doctype declarations was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.nifi:nifi-standard-processors≥ 0.1.0&&< 1.6.01.6.0org.apache.nifi:nifi-standard-processors:1.6.0

Affected Products

1 product · 1 configurations
Application
nifiapache
< 1.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-standard-processors, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.nifi:nifi-standard-processors to 1.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1309 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Apache NiFi External XML Entity issue in SplitXML processor. Malicious XML content could cause information disclosure or remote code execution. The fix to disable external general entity parsing and disallow doctype declarations was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
O3 Security · Impact-Aware SCA

Is CVE-2018-1309 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1309: nifi-standard RCE — Fixed in 1.6.0