CVE-2018-1286 — openmeetings-parent
MEDIUMCVE-2018-1286 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in org.apache.openmeetings:openmeetings-parent. A fix is available for org.apache.openmeetings:openmeetings-parent — see the affected versions and patch details below.
Apache OpenMeetings may allow authenticated attacker to deny service for privileged users
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.openmeetings:openmeetings-parentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache OpenMeetings 3.0.0 - 4.0.1, CRUD operations on privileged users are not password protected allowing an authenticated attacker to deny service for privileged users. The issue is fixed in version 4.0.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.openmeetings:openmeetings-parent | ≥ 3.0.0&&< 4.0.2 | 4.0.2org.apache.openmeetings:openmeetings-parent:4.0.2 |
Affected Products
openmeetingsapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.openmeetings:openmeetings-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.openmeetings:openmeetings-parent to 4.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1286 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-1286 in your dependencies?
Find it across Maven, including transitive dependencies.