NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-12537 — vertx-core

MEDIUMFix: eclipse/vert.x@1bb6445

CVE-2018-12537 is a medium-severity (CVSS 5.3) CWE-93 vulnerability in io.vertx:vertx-core. A fix is available for io.vertx:vertx-core — see the affected versions and patch details below.

Moderate severity vulnerability that affects io.vertx:vertx-core

Also known asGHSA-6cw8-7j6c-hccp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.54%1.35%2.17%2.98%1.0%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.vertx:vertx-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Eclipse Vert.x version 3.0 to 3.5.1, the HttpServer response headers and HttpClient request headers do not filter carriage return and line feed characters from the header value. This allow unfiltered values to inject a new header in the client request or server response.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.vertx:vertx-core≥ 3.0.0&&< 3.5.23.5.2io.vertx:vertx-core:3.5.2

Affected Products

1 product · 1 configurations
Application
vert.xeclipse
≥ 3.0.0 && ≤ 3.5.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.vertx:vertx-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.vertx:vertx-core to 3.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-12537 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

While the affected artifact is being shipped in Fuse 6.3 via camel-vertx component, the vulnerable code is not being used, therefore Fuse 6.3 is not affected.

ProductFixed inAdvisory
Red Hat Fuse 7.2vertxRHSA-2018:3768
Text-Only RHOARvertxRHSA-2018:2371

Frequently Asked Questions

In Eclipse Vert.x version 3.0 to 3.5.1, the HttpServer response headers and HttpClient request headers do not filter carriage return and line feed characters from the header value. This allow unfiltered values to inject a new header in the client request or server response.
O3 Security · Impact-Aware SCA

Is CVE-2018-12537 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-12537: vertx-core — Fixed in 3.5.2