NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2018-11647 — oauth2orize-fprm

MEDIUMFix: jaredhanson/oauth2orize-fprm@2bf9fae

CVE-2018-11647 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in oauth2orize-fprm. A fix is available for oauth2orize-fprm — see the affected versions and patch details below.

oauth2orize-fprm XSS vulnerability

Also known asGHSA-p77r-c6m3-gj2r
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
oauth2orize-fprmnpm
32downloads / week

Description

index.js in oauth2orize-fprm before 0.2.1 has XSS via a crafted URL.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmoauth2orize-fprmall versions0.2.1npm install oauth2orize-fprm@0.2.1

Affected Products

1 product · 1 configurations
Application
oauth2orize-fprmoauth2orize-fprm_project
< 0.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oauth2orize-fprm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update oauth2orize-fprm to 0.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11647 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

index.js in oauth2orize-fprm before 0.2.1 has XSS via a crafted URL.
O3 Security · Impact-Aware SCA

Is CVE-2018-11647 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-11647: oauth2orize-fprm XSS — Fixed in 0.2.1