CVE-2018-1134 — moodle
MEDIUMCVE-2018-1134 is a medium-severity (CVSS 6.5) Improper Privilege Management vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Improper Privilege Management
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Moodle 3.x. Students who submitted assignments and exported them to portfolios can download any stored Moodle file by changing the download URL.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.1&&< 3.1.12 | 3.1.12composer require moodle/moodle:^3.1.12 |
| 🐘Packagist | moodle/moodle | ≥ 3.2&&< 3.2.9 | 3.2.9composer require moodle/moodle:^3.2.9 |
| 🐘Packagist | moodle/moodle | ≥ 3.3&&< 3.3.6 | 3.3.6composer require moodle/moodle:^3.3.6 |
| 🐘Packagist | moodle/moodle | ≥ 3.4&&< 3.4.3 | 3.4.3composer require moodle/moodle:^3.4.3 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1134 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2018-1134 in your dependencies?
Find it across Packagist, including transitive dependencies.