NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-10894 — keycloak-saml-adapter-core

MEDIUMFix: keycloak/keycloak@812e76c

CVE-2018-10894 is a medium-severity (CVSS 5.4) CWE-345 vulnerability in org.keycloak:keycloak-saml-adapter-core. A fix is available for org.keycloak:keycloak-saml-adapter-core — see the affected versions and patch details below.

Keycloak Authentication Error

Also known asGHSA-xvv8-8wh9-9fh2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.keycloak:keycloak-saml-adapter-core☕org.keycloak:keycloak-services

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. A malicious user could use this to access unauthorized data or possibly conduct further attacks.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-saml-adapter-coreall versions4.4.0.Finalorg.keycloak:keycloak-saml-adapter-core:4.4.0.Final
☕Mavenorg.keycloak:keycloak-servicesall versions4.4.0.Finalorg.keycloak:keycloak-services:4.4.0.Final

Affected Products

2 products · 2 configurations
Application
keycloakredhat
1 version
3.4.3
Application
single sign-onredhat
1 version
7.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-saml-adapter-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-saml-adapter-core to 4.4.0.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10894 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Single Sign-On 7.2.5 zipserverRHSA-2018:3595
Red Hat Single Sign-On 7.2 for RHEL 6rh-sso7-keycloak-0:3.4.14-1.Final_redhat_00001.1.jbcs.el6RHSA-2018:3592
Red Hat Single Sign-On 7.2 for RHEL 7rh-sso7-keycloak-0:3.4.14-1.Final_redhat_00001.1.jbcs.el7RHSA-2018:3593
Text-Only RHOARsee advisoryRHSA-2019:0877

Frequently Asked Questions

It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. A malicious user could use this to access unauthorized data or possibly conduct further attacks.
O3 Security · Impact-Aware SCA

Is CVE-2018-10894 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-10894: Fixed in 4.4.0.Final (Medium 5.4)