NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2018-10891 — moodle

HIGHFix: moodle/moodle@0b18d0c

CVE-2018-10891 is a high-severity (CVSS 7.3) Improper Input Validation vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle XSS Vulnerability

Also known asGHSA-p7v9-gjrh-563x
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.89%1.78%2.67%0.3%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.5.0&&< 3.5.13.5.1composer require moodle/moodle:^3.5.1
🐘Packagistmoodle/moodle≥ 3.4.0&&< 3.4.43.4.4composer require moodle/moodle:^3.4.4
🐘Packagistmoodle/moodle≥ 3.3.0&&< 3.3.73.3.7composer require moodle/moodle:^3.3.7
🐘Packagistmoodle/moodle≥ 3.2.0&&< 3.2.103.2.10composer require moodle/moodle:^3.2.10
🐘Packagistmoodle/moodle≥ 3.1.0&&< 3.1.133.1.13composer require moodle/moodle:^3.1.13

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 3.5 && < 3.5.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10891 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.
O3 Security · Impact-Aware SCA

Is CVE-2018-10891 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-10891: moodle — Fixed in 3.5.1