NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-1045 — moodle

MEDIUM

CVE-2018-1045 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle XSS Vulnerability

Also known asGHSA-595j-wpfg-23w4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.47%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 3.x, there is XSS via a calendar event name.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.3&&< 3.3.43.3.4composer require moodle/moodle:^3.3.4
🐘Packagistmoodle/moodle≥ 3.2&&< 3.2.73.2.7composer require moodle/moodle:^3.2.7
🐘Packagistmoodle/moodle≥ 3.1&&< 3.1.103.1.10composer require moodle/moodle:^3.1.10

Affected Products

1 product · 12 configurations
Application
moodlemoodle
≤ 3.1.9
11 versions
3.2.03.2.13.2.23.2.33.2.43.2.53.2.63.3.03.3.13.3.23.3.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1045 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Moodle 3.x, there is XSS via a calendar event name.
O3 Security · Impact-Aware SCA

Is CVE-2018-1045 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-1045: moodle XSS — Fixed in 3.3.4