Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
CISA KEV · ACTIVELY EXPLOITED
CRITICAL severity

CVE-2018-1000861 — jenkins-core

CRITICALFix: jenkinsci/jenkins@47f38d7

CVE-2018-1000861 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.jenkins-ci.main:jenkins-core. It is in CISA's Known Exploited Vulnerabilities catalog (added 2022-02-10) — treat it as actively exploited and patch now. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Deserialization of Untrusted Data in Jenkins

Also known asGHSA-hhpm-5cp2-hg4x
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
6 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2022-02-10. Federal agencies were required to remediate by 2022-08-10.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2018-1000861.

EPSS Exploitation Probability

via FIRST.org ↗
98.3%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
93.3%95.4%97.4%99.5%94.5%98.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2018-1000861 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in stapler/core/src/main/java/org/kohsuke/stapler/MetaClass.java that allows attackers to invoke some methods on Java objects by accessing crafted URLs that were not intended to be invoked this way.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.138.4org.jenkins-ci.main:jenkins-core:2.138.4
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.140&&< 2.1542.154org.jenkins-ci.main:jenkins-core:2.154

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≤ 2.153
range
Application
openshift container platformredhat
1 version
3.11
Exploits & PoCs
6

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.138.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000861 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

How to detect CVE-2018-1000861

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-1000861 -u https://target
Template
Jenkins - Remote Command Injection
Severity
critical
Impact
Successful exploitation of this vulnerability can lead to unauthorized access, data leakage, and potential compromise of the entire Jenkins server.
Remediation
Apply the latest security patches and updates provided by Jenkins to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (dhiyaneshDK, pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability is only exploitable by a user with developer permissions. Therefore this vulnerability is rated Important for OpenShift Container Platform 3.x.

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-0:2.138.4.1544416383-1.el7RHBA-2019:0024

Frequently Asked Questions

A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in stapler/core/src/main/java/org/kohsuke/stapler/MetaClass.java that allows attackers to invoke some methods on Java objects by accessing crafted URLs that were not intended to be invoked this way.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000861 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000861: jenkins-core (Critical 9.8, KEV)