NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000529 — fields

MEDIUM

CVE-2018-1000529 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.grails.plugins:fields. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.grails.plugins:fields — see the affected versions and patch details below.

Stored Cross Site Scripting in Grails Fields Plugin

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Oct 22, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.10%1.66%0.3%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.grails.plugins:fields☕org.grails:grails-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.grails.plugins:fieldsall versions2.2.8org.grails.plugins:fields:2.2.8
☕Mavenorg.grails:grails-coreall versions3.3.6org.grails:grails-core:3.3.6

Affected Products

1 product · 1 configurations
Application
grails fieldsgrails
1 version
2.2.7
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.grails.plugins:fields, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.grails.plugins:fields to 2.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000529 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000529 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000529: fields XSS — Fixed in 2.2.8