NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000202 — groovy-postbuild

MEDIUM

CVE-2018-1000202 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jvnet.hudson.plugins:groovy-postbuild. A fix is available for org.jvnet.hudson.plugins:groovy-postbuild — see the affected versions and patch details below.

Jenkins Groovy Postbuild Plugin vulnerable to Cross-site Scripting

Also known asGHSA-38ch-x695-m794
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.1%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jvnet.hudson.plugins:groovy-postbuild

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jvnet.hudson.plugins:groovy-postbuildall versions2.4org.jvnet.hudson.plugins:groovy-postbuild:2.4

Affected Products

1 product · 1 configurations
Application
groovy postbuildjenkins
≤ 2.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jvnet.hudson.plugins:groovy-postbuild, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jvnet.hudson.plugins:groovy-postbuild to 2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000202 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000202 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000202: groovy-postbuild XSS — Fixed in 2.4