CVE-2018-1000025 is a high-severity (CVSS 8.1) CWE-732 vulnerability in kreait/firebase-php. A fix is available for kreait/firebase-php — see the affected versions and patch details below.
Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
kreait/firebase-phpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | kreait/firebase-php | ≥ 3.2.0&&< 3.8.1 | 3.8.1composer require kreait/firebase-php:^3.8.1 |
Affected Products
firebase admin sdk for phpfirebase_admin_sdk_for_php_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kreait/firebase-php, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update kreait/firebase-php to 3.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000025 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-1000025 in your dependencies?
Find it across Packagist, including transitive dependencies.