NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2018-0787 — Microsoft.AspNetCore.Http…

HIGH

CVE-2018-0787 is a high-severity (CVSS 8.8) CWE-640 vulnerability in Microsoft.AspNetCore.HttpOverrides. A fix is available for Microsoft.AspNetCore.HttpOverrides — see the affected versions and patch details below.

ASP.NET Core allow an elevation of privilege

Also known asGHSA-365p-96qv-xr7g
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.20%11.4%15.6%19.8%17.5%9.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETMicrosoft.AspNetCore.HttpOverrides.NETMicrosoft.AspNetCore.Server.Kestrel.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.HttpOverrides≥ 2.0.0&&< 2.0.22.0.2dotnet add package Microsoft.AspNetCore.HttpOverrides --version 2.0.2
.NETNuGetMicrosoft.AspNetCore.Server.Kestrel.Core≥ 2.0.0&&< 2.0.22.0.2dotnet add package Microsoft.AspNetCore.Server.Kestrel.Core --version 2.0.2

Affected Products

1 product · 3 configurations
Application
asp.net coremicrosoft
3 versions
1.01.12.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.HttpOverrides, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.HttpOverrides to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-0787 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".
O3 Security · Impact-Aware SCA

Is CVE-2018-0787 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2018-0787: Microsoft.AspNetCore — Fixed in 2.0.2