NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-9802 — org.apache.sling.servlets…

MEDIUM

CVE-2017-9802 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.sling:org.apache.sling.servlets.post. A fix is available for org.apache.sling:org.apache.sling.servlets.post — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation Apache Sling Servlets Post

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.53%3.05%4.58%0.6%3.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.sling:org.apache.sling.servlets.post

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Javascript method Sling.evalString() in Apache Sling Servlets Post before 2.3.22 uses the javascript 'eval' function to parse input strings, which allows for XSS attacks by passing specially crafted input strings.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.sling:org.apache.sling.servlets.postall versions2.3.22org.apache.sling:org.apache.sling.servlets.post:2.3.22

Affected Products

1 product · 1 configurations
Application
sling servlets postapache
≤ 2.3.20
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.sling:org.apache.sling.servlets.post, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.sling:org.apache.sling.servlets.post to 2.3.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9802 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The Javascript method Sling.evalString() in Apache Sling Servlets Post before 2.3.22 uses the javascript 'eval' function to parse input strings, which allows for XSS attacks by passing specially crafted input strings.
O3 Security · Impact-Aware SCA

Is CVE-2017-9802 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-9802: org.apache.sling XSS — Fixed in 2.3.22