NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2017-8046 — spring-data-rest-core

CRITICAL

CVE-2017-8046 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.springframework.data:spring-data-rest-core. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.data:spring-data-rest-core — see the affected versions and patch details below.

Remote code execution in PATCH requests in Spring Data REST

Also known asGHSA-9qf9-28h9-hqcj
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
8 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
74.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
66.4%77.6%88.8%100.0%94.0%74.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework.data:spring-data-rest-core☕org.springframework.data:spring-data-rest-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON data to run arbitrary Java code.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.data:spring-data-rest-coreall versions2.6.9.RELEASEorg.springframework.data:spring-data-rest-core:2.6.9.RELEASE
☕Mavenorg.springframework.data:spring-data-rest-core≥ 3.0.0&&< 3.0.1.RELEASE3.0.1.RELEASEorg.springframework.data:spring-data-rest-core:3.0.1.RELEASE

Affected Products

3 products · 15 configurations
Application
spring data restpivotal_software
1 version
3.0.0
Application
spring bootvmware
< 1.5.9
1 version
2.0.0
Application
spring data restvmware
< 2.6.9
1 version
3.0.0
Exploits & PoCs
8

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44289webappsjava

Spring Data REST < 2.6.9 (Ingalls SR9) / 3.0.1 (Kay SR1) - PATCH Request Remote Code Execution

by Antonio Francesco Sardella · Mar 15, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.data:spring-data-rest-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.data:spring-data-rest-core to 2.6.9.RELEASE or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8046 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2017-8046

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2017-8046 -u https://target
Template
Spring Data REST < 2.6.9 (Ingalls SR9) / 3.0.1 (Kay SR1) - PATCH Request Remote Code Execution
Severity
critical
Impact
Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON data to run arbitrary Java code.
Remediation
To remediate this vulnerability, update to Spring Data REST version 2.6.9 or later, or 3.0.1 or later, and Spring Boot version 1.5.9 or later, or 2.0 M6 or later.

Template by ProjectDiscovery nuclei-templates (domwhewell-sage), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

While there might be compatibility issues upgrading Spring REST Data independently of the Spring Boot version we recommend that customers make sure they are using a fixed version of Spring Data REST 2.6.9, or 3.0.1. RHOAR has now upgraded to version 1.5.10 of Spring Boot which is compatible with fixed versions of…

ProductFixed inAdvisory
Red Hat Fuse Intergration Services 2.0 based on Fuse 6.3 R7spring-bootRHSA-2018:2405

Frequently Asked Questions

Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON data to run arbitrary Java code.
O3 Security · Impact-Aware SCA

Is CVE-2017-8046 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-8046: spring-data-rest-core — Fix Available