NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-7684 — openmeetings-parent

HIGH

CVE-2017-7684 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.apache.openmeetings:openmeetings-parent. A fix is available for org.apache.openmeetings:openmeetings-parent — see the affected versions and patch details below.

Apache OpenMeetings vulnerable to Uncontrolled Resource Consumption

Also known asGHSA-g3vq-f35v-vhgm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.00%1.77%2.54%3.31%1.5%2.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.openmeetings:openmeetings-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache OpenMeetings 1.0.0 doesn't check contents of files being uploaded. An attacker can cause a denial of service by uploading multiple large files to the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.openmeetings:openmeetings-parent≥ 1.0.0&&< 3.3.03.3.0org.apache.openmeetings:openmeetings-parent:3.3.0

Affected Products

1 product · 21 configurations
Application
openmeetingsapache
21 versions
1.0.02.02.12.1.12.2.03.0.03.0.13.0.23.0.33.0.43.0.53.0.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.openmeetings:openmeetings-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.openmeetings:openmeetings-parent to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7684 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Apache OpenMeetings 1.0.0 doesn't check contents of files being uploaded. An attacker can cause a denial of service by uploading multiple large files to the server.
O3 Security · Impact-Aware SCA

Is CVE-2017-7684 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-7684: openmeetings-parent DoS — Fixed in 3.3.0