NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2017-7673 — openmeetings-parent

CRITICAL

CVE-2017-7673 is a critical-severity (CVSS 9.8) CWE-307 vulnerability in org.apache.openmeetings:openmeetings-parent. A fix is available for org.apache.openmeetings:openmeetings-parent — see the affected versions and patch details below.

Apache OpenMeetings has Inadequate Encryption Strength

Also known asGHSA-cqm6-hrgq-6869
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.72%1.43%2.15%0.4%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.openmeetings:openmeetings-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache OpenMeetings 1.0.0 uses not very strong cryptographic storage, captcha is not used in registration and forget password dialogs and auth forms missing brute force protection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.openmeetings:openmeetings-parent≥ 1.0.0&&< 3.3.03.3.0org.apache.openmeetings:openmeetings-parent:3.3.0

Affected Products

1 product · 21 configurations
Application
openmeetingsapache
21 versions
1.0.02.02.12.1.12.2.03.0.03.0.13.0.23.0.33.0.43.0.53.0.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.openmeetings:openmeetings-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.openmeetings:openmeetings-parent to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7673 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache OpenMeetings 1.0.0 uses not very strong cryptographic storage, captcha is not used in registration and forget password dialogs and auth forms missing brute force protection.
O3 Security · Impact-Aware SCA

Is CVE-2017-7673 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-7673: openmeetings-parent — Fixed in 3.3.0